Devel and PR jobs broken after recent Jenkins upgrade.
Incident Report for ROS
Resolved
Devel and PR jobs on both farms ran as expected overnight and a re-triggering of builds which errored due to the issue has also turned up no further regressions.
Posted Apr 23, 2021 - 14:03 UTC
Monitoring
The minimal plugin updates required to resolve the issue have been deployed to both build farms.
Devel and PR jobs have been re-enabled and re-configured to restore any configurations affected by the plugin incompatibility window.

In the morning we'll review job results overnight and determine if this resolution is complete or if there are any other recurring issues.
Posted Apr 23, 2021 - 04:28 UTC
Identified
We have found a plugin version that is compatible with our configuration have upgraded build.ros2.org to that plugin version. After some hiccups in verification there we're on a path to restored service. Once complete we'll do the same for build.ros.org.
Posted Apr 23, 2021 - 03:06 UTC
Investigating
Devel and PR jobs across both build.ros.org and build.ros2.org are currently disabled after a security-related Jenkins upgrade brought additional breaking changes. We are investigating a number of potential fixes and workarounds.

https://github.com/ros-infrastructure/ros_buildfarm/issues/871
Posted Apr 23, 2021 - 00:02 UTC