GPG Key Expired
Incident Report for ROS
Postmortem

The postmortem for this incident has been posted to ROS Discourse here

Posted Jun 04, 2021 - 21:42 UTC

Resolved
Open Robotics infrastructure has been updated throughout to use the republished key and we're not currently aware of any further impacts to existing services.
Posted Jun 03, 2021 - 22:46 UTC
Monitoring
Updated keys have been posted. There's more information at: https://discourse.ros.org/t/ros-gpg-key-expiration-incident/20669 User intervention is required. Please see that thread for more information. We will keep monitoring the situation.
Posted May 29, 2021 - 08:22 UTC
Identified
We have extended the GPG expiration and are in the process of deploying it to the various systems. Our deployment is in process. We expect that there will be a requirement for users to update their systems, more information will be forthcoming.
Posted May 29, 2021 - 06:59 UTC
Investigating
The GPG key for packages.ros.org term has expired.
Posted May 29, 2021 - 04:32 UTC